ccaas-status - Degraded performance due to Microsoft issues – Incident details

All systems operational

Degraded performance due to Microsoft issues

Resolved
Operational
Started about 3 years agoLasted about 5 hours

Affected

Graia Contact Center as a Service

Operational from 7:45 AM to 1:02 PM

CCaaS Europe - Voice Services

Operational from 7:45 AM to 1:02 PM

CCaaS International - Email Services

Operational from 7:45 AM to 1:02 PM

CCaaS International - Chat & Social Media

Operational from 7:45 AM to 1:02 PM

CCaaS International - Reporting & Wallboard

Operational from 7:45 AM to 1:02 PM

CCaaS International - Admin Portal

Operational from 7:45 AM to 1:02 PM

Updates
  • Resolved
    Resolved

    Dear customer, We would like to inform you that Microsft resolved the issues on their side and everything is now working as expected. Thank you for your patience! Buzzeasy Team

  • Update
    Update

    Microsoft identified and fixed the issues: "We have identified a recent change to WAN as the underlying cause, and have taken steps to roll back this change. Our telemetry shows consistent signs of recovery from 09:45 UTC onwards across multiple regions and services. Most customers should now see full recovery as WAN networking has recovered fully. " Our systems are back at full functionality.

  • Investigating
    Investigating

    Dear customer, We would like to inform you that we are experiencing degraded performance due to ongoing issues on Microsoft side. Different services seem to be affected for different geographical areas. More details here, on their official account: https://twitter.com/MSFT365Status/status/1618149579341369345?cxt=HHwWgsC44YKe6fQsAAAA We will keep you updated. Thank you for understanding! Buzzeasy Team