ccaas-status - Customers are experiencing problems with voice campaigns – Incident details

All systems operational

Customers are experiencing problems with voice campaigns

Resolved
Partial outage
Started over 2 years agoLasted about 5 hours

Affected

Graia Contact Center as a Service

Partial outage from 9:15 AM to 1:48 PM

CCaaS Europe - Voice Services

Partial outage from 9:15 AM to 1:48 PM

Updates
  • Update
    Update

    The system has now returned to working order. We're sorry for the inconveniences this incident may have caused.

  • Investigating
    Investigating

    Some customers are seeing stuck campaign records. We’re aware of the issue and are working on it urgently. We’re really sorry to be holding you up today! Please know our teams are working hard to get everything up and running, and we will update you with the latest information as they become available.