ccaas-status - Inbound emails not received by Graia email channels – Incident details

All systems operational

Inbound emails not received by Graia email channels

Resolved
Partial outage
Started 6 months agoLasted about 12 hours

Affected

Graia Contact Center as a Service

Partial outage from 7:00 AM to 7:00 PM

CCaaS International - Email Services

Partial outage from 7:00 AM to 7:00 PM

Updates
  • Update
    Update

    Related DevOps workitems: Incident 138175: Inbound emails not arriving into Graia Bug 136453: emailbots pod using 3.3 GiB

  • Update
    Update

    Root Cause: With the release of a bugfix pertaining to the emailbots service, another issue was unfortunately introduced: the “Wait For Customer Reply” email workflow node works in a way that it periodically checks whether the awaited reply has arrived or the timeout reached. If it needs to wait some more, it signals this with delayed queue messages. The introduced bug was that in such cases, the service not only queued a new message but it also requeued the original one. This led to exponential growth of messages in the queue. Because the messages are drained sequentially, newer messages that got introduced after the exponentially duplicated ones were waiting for their turn to be processed. This meant the email conversations were stuck at a point in their workflow that required the processing of messages in the queue.

  • Update
    Update

    The incident has been resolved

  • Investigating
    Investigating

    We are experiencing a problem receiving inbound emails at the moment. We are investigating this with high priority. Outbound emails are working.