ccaas-status - Calls unresponsive at agents – Incident details

All systems operational

Calls unresponsive at agents

Resolved
Degraded performance
Started about 1 month agoLasted 18 minutes

Affected

Graia Contact Center as a Service

Degraded performance from 11:50 AM to 12:03 PM, Operational from 12:03 PM to 12:08 PM

CCaaS Europe - Voice Services

Degraded performance from 11:50 AM to 12:03 PM, Operational from 12:03 PM to 12:08 PM

Updates
  • Postmortem
    Postmortem

    The incident was caused by a third-party voice gateway component becoming overloaded under specific high-load conditions.

    This overload triggered a software defect in the component, leading to worker thread conflicts. As a result, voice client connectivity for affected calls was disrupted, causing loss of call control and audio handling failures.


    Corrective Action Plan:

    Call Probing Implementation

    Automated Stuck Call Handling

  • Resolved
    Resolved

    Agents continued to experience effects from calls that were already active during the incident (e.g. calls stuck, no audio, inability to end or retrieve calls). New calls established after recovery were handled normally.

  • Monitoring
    Monitoring

    Successful outbound call from the recovered service was observed.

  • Identified
    Identified

    A telephony service on one of the EU customer virtual machines experienced a software crash.
    Automatic recovery restarted the affected service.

  • Investigating
    Investigating

    Agents began reporting symptoms of unresponsive or silent calls.