ccaas-status - QueueChatConnectorService SF app undeployed, unable to redeploy – Incident details

All systems operational

QueueChatConnectorService SF app undeployed, unable to redeploy

Resolved
Major outage
Started over 4 years agoLasted 11 minutes

Affected

Graia Contact Center as a Service

Major outage from 6:54 AM to 7:05 AM

CCaaS International - Contact Expert Chat Services

Major outage from 6:54 AM to 7:05 AM

Updates
  • Resolved
    Resolved

    Upon regenerating a secret, the deployment went through fine. Tenant Manager service principal details are in the tenantmanagerprod KeyVault. The service principal object is in Buzzeasy Azure AD.

  • Investigating
    Investigating

    During the night SRE team realized the QMS service was acting up again, and reported to RTE team to perform remedial action (undeploy / redeploy in SF). Unfortunately a different service (QCC in title) was undepkloyed instaed. The problem was quickly discovered and QMS was handled, however the QCC was redeploy was unsuccessful. This is an older service used by CE tenants for chat connection to the chat providers via BE. BE itself does not use this service. Because of its age, QCC deployment is still done using Tenant Manager, and since not much else in the BE world is using it, its AAD service principal secret has expired quite some time ago. Upon generating a new secret, the deployment went on fine.