ccaas-status - Calls not going through – Incident details

All systems operational

Calls not going through

Resolved
Major outage
Started almost 3 years agoLasted about 3 hours

Affected

Graia Contact Center as a Service

Major outage from 9:15 AM to 12:28 PM

CCaaS Europe - Voice Services

Major outage from 9:15 AM to 12:28 PM

CCaaS International - Email Services

Major outage from 9:15 AM to 12:28 PM

CCaaS International - Chat & Social Media

Major outage from 9:15 AM to 12:28 PM

CCaaS International - Core Services

Major outage from 9:15 AM to 12:28 PM

Updates
  • Update
    Update

    The incident has been resolved

  • Update
    Update

    Inbound calls are now being successfully assigned to agents. Buzzeasy is fully operational again. Thank you for understanding!

  • Update
    Update

    Some tenants are still experiencing problems with calls not being assigned to agents. Continuing the investigation. Thank you for understanding!

  • Update
    Update

    Dear Buzzeasy customer, Please be informed that services are back up and running. Keeping the system under observation for now. Thank you for understanding! Buzzeasy Team

  • Update
    Update

    Update: We are currently impacted by an Azure outage affecting multiple services. Microsoft Tracking ID: VLB8-1Z0 Will come back with updates as soon as possible. Thank you for understanding, Buzzeasy Team

  • Update
    Update

    Dear Buzzeasy customers, Please be informed that we are currently experiencing some issues and calls are not being processed as expected. We are currently investigating and will get back to you with an update as soon as possible. Thank you for understanding, Buzzeasy Team

  • Investigating
    Investigating

    Dear Buzzeasy customers, Please be informed that we are currently experiencing some issues and calls are not being processed as expected. We are currently investigating and will get back to you with an update as soon as possible. Thank you for understanding, Buzzeasy Team