ccaas-status - Failures in chat transfers to Cisco – Incident details

All systems operational

Failures in chat transfers to Cisco

Resolved
Partial outage
Started about 1 year agoLasted about 1 hour

Affected

Graia Contact Center as a Service

Partial outage from 12:03 PM to 12:48 PM

CCaaS Custom Connectors to Cisco

Partial outage from 12:03 PM to 12:48 PM

Updates
  • Update
    Update

    First occurrence of the pertinent error message in Vivacom's log file "UGBuzzeasyCiscoConnector-20250221.log": 2025-02-21 12:03:25.963 [Error] UGBuzzeasyCiscoConnector.HostedServices.CiscoApplicationService error requesting entry point (1009) configuration (status:Unauthorized) {"code":"401-109","developerMessage":"Invalid or expired 'Authorization' header provided. New access token is required."} Log line in the same file that indicated the renewal of the token. Note that this is missing the beginning of the line but happened some time between 2025-02-21 12:50:39 and 2025-02-21 12:50:20: 6be06f1d09c4","expires_in":86400,"token_type":"Bearer"}

  • Investigating
    Investigating

    One customer reported failures of transfers of chat conversations to their Cisco agent application. Investigation revealed that these were due premature expiration of an access token. A restart of the relevant resource forced the system to require a new access token which allowed continued communication between the relevant parties.