Scheduled for August 02, 2025 at 3:00 AM – 5:00 AM
Affects
Graia Contact Center as a Service
Under maintenance from 3:00 AM to 5:00 AM
CCaaS Europe - Voice Services
Under maintenance from 3:00 AM to 5:00 AM
CCaaS Americas - Voice Services
Under maintenance from 3:00 AM to 5:00 AM
Updates
Update
August 02, 2025 at 5:59 AM
Update
August 02, 2025 at 5:59 AM
The maintenance has been completed
In progress
August 02, 2025 at 4:58 AM
In progress
August 02, 2025 at 4:58 AM
We need extend the maintenance window by approx. 30 minutes. Thank you for your patience.
Planned
August 02, 2025 at 3:00 AM
Planned
August 02, 2025 at 3:00 AM
Dear Buzzeasy Customer,
We would like to inform you that on 02-08-2025 there will be a scheduled maintenance window for applying security patches on the Buzzeasy Voice components.
Buzzeasy International: 02-08-2025 | 03:00 UTC | 2 h
During this time all Buzzeasy components will be operational, but we do anticipate a short voice service interruption during key moments of the update.
Thank you for your patience. If you have any questions, please contact us via the known communication channels.
Kind Regards,
Buzzeasy Team